IBM Support

Installing IBM Security Guardium S-TAP (STAP) via GIM disappears from S-TAP Control after appearing for a short period of time.

Troubleshooting


Problem

You are using IBM Security Guardium Installation Manager (GIM) to install a new STAP on a Windows server. After you start the STAP installation from the GIM Graphical User Interface (GUI) interface, the installation starts. Eventually, the new STAP appears listed under the S-TAP Control List on the GUI of the Guardium collector you configured for this STAP. However, the STAP disappears from the S-TAP Control List shortly after it appears. No errors are reported on the GIM GUI or on the STAP install messages viewable from the GIM GUI. Note: This technote discusses one of many possible causes for this problem and how to resolve it. If your environment does not meet the conditions listed in section Diagnosing the Problem of this technote, the solution discussed in this article does not apply to your situation.

Cause

Installer's attempt to upgrade the VC++ libraries on this server failed. Installation is unable to locate the existing (to be upgraded) Visual C++ Redistributable in the expected location. This is a known issue with Microsoft Windows.
Refer to the following Microsoft links for more information:

http://blogs.msdn.com/b/vsnetsetup/archive/2012/01/23/issues-with-the-installation-of-vc-redistributable-packages-error-the-feature-you-are-tryi

http://answers.microsoft.com/en-us/windows/forum/windows_xp-windows_update/error-1714-cant-find-file-vcredistmsi-when-try-to/b8cacf7b-1720-4b49-

Environment

STAP 9.5 on Windows Server

Diagnosing The Problem

You are in presence of this problem if both conditions below are met:

1.- Review log file guardiumStapLog.txt , located in the main drive of the server (ie. C:\guardiumStapLog.txt).

Last message logged indicates the installer called the VC++ executable vcredist_x64.exe.

Last two lines in the log are similar to these (Timestamp and registry key number may be different):



(line a)  7-21-2017 14:30:19: Install VC Redist - start
(line b)  7-21-2017 14:30:19: Running:  
       C:\Windows\TEMP\{32697E69-9C52-4A91-90D4-0D0C79DB53A9}\vcredist_x64.exe /q:a

(line a) indicates it will attempt to Install the Visual C (VC) distributable while (line b) is the command that was executed to do this. The fact that no more messages where logged to this log after the command, means the command did not finish successfully. Something happened when the command was trying to upgrade the VC++ distributable.

Below is a bigger sample fragment of the last lines from this file:


    7-21-2017 14:30:19: Searching for Dob installation..
    7-21-2017 14:30:19: Searching for Canaan installation..
    7-21-2017 14:30:19: Searching for Existing service: lhmonproxy
    7-21-2017 14:30:19: Searching for Existing service: nttdidr
    7-21-2017 14:30:19: Searching for Existing service: nptrc
    7-21-2017 14:30:19: Searching for Existing service: npproxy
    7-21-2017 14:30:19: Searching for Existing service: lpctrc
    7-21-2017 14:30:19: Searching for Existing service: GUARDIUM Database Monitor
    7-21-2017 14:30:19: Searching for Existing service: drvtrc
    7-21-2017 14:30:19: Searching for Existing service: GUARDIUM_STAP
    7-21-2017 14:30:19: Searching for Existing service: libldr
    7-21-2017 14:30:19: Searching for Existing service: casclient
    7-21-2017 14:30:19: enter OnBegin
    7-21-2017 14:30:19: Install VC Redist - start
    7-21-2017 14:30:19: Running:  C:\Windows\TEMP\{32697E69-9C52-4A91-90D4-0D0C79DB53A9}\vcredist_x64.exe /q:a


2.- Review GIM.log file the GIM's installation directory. It contains this error (it may not be the last line):
    -E- Setup failed to initialize!  

The "-E-" means ERROR.
The message " -E- Setup failed to initialize!"


Below is a bigger sample fragment of the last lines from the GIM.log file:


    14:29:58, Fri Jul 21, 2017  : Verifying package: guard-WINSTAP-elkhound_r89963_1-Windows-Server_2003-Windows-586.exe.signed
    14:30:0, Fri Jul 21, 2017  : unpack guard-WINSTAP-elkhound_r89963_1-Windows-Server_2003-Windows-586.exe.signed.exe in C:\Program Files (x86)\Guardium\Guardium Installation Manager\\WINSTAP\current
    14:30:9, Fri Jul 21, 2017  : windows package: WINSTAP  Action:
    14:30:9, Fri Jul 21, 2017  : --I-- gethook:
    14:30:9, Fri Jul 21, 2017  : --I-- Running hook: WINSTAP_hooks::install()
    14:30:9, Fri Jul 21, 2017  : --I-- hook returned: /s /z"NTXD1864;c:\program files (x86)\Guardium\stap;C:\Guard_20170425143009; START=1"
    14:30:9, Fri Jul 21, 2017  : Launching: "C:\Program Files (x86)\Guardium\Guardium Installation Manager\WINSTAP\current\setup.exe" /s /z"NTXD1864;c:\program files (x86)\Guardium\stap;C:\Guard_20170425143009; START=1"
    14:38:29, Fri Jul 21, 2017  : -E- Setup failed to initialize! (Fri Jul 21 14:38:29 2017)
    14:38:30, Fri Jul 21, 2017  : -I- Updating server
    14:38:30, Fri Jul 21, 2017  : -I- Sending CHECK_UPDATES request to server
    14:38:31, Fri Jul 21, 2017  : -I- No packages to install...seeking for conf.reload
    14:38:31, Fri Jul 21, 2017  : -I- looking for  C:\Program Files (x86)\Guardium\Guardium Installation Manager\/gim/current/conf.reload
    14:38:31, Fri Jul 21, 2017  : -I- UPDATING MODULES under C:\Program Files (x86)\Guardium\Guardium Installation Manager\!!!
    14:38:31, Fri Jul 21, 2017  : -I- Updating module GIM
    14:38:31, Fri Jul 21, 2017  : -I- Updating server
    14:38:31, Fri Jul 21, 2017  : -I- Sending CHECK_UPDATES request to server
    14:38:31, Fri Jul 21, 2017  : -I- No packages to install...seeking for conf.reload
    14:38:31, Fri Jul 21, 2017  : -I- looking for  C:\Program Files (x86)\Guardium\Guardium Installation Manager\/gim/current/conf.reload
    14:38:31, Fri Jul 21, 2017  : -I- Returned to alive message loop


Resolving The Problem

Permanent Solution:
1.- Uninstall the existing VC++ libraries from the server

2.- Install the latest VC++ libraries on the server (refer to our Windows Team or to Microsoft for assistance if needed)

3.- Reinstall the Guardium STAP again  (first uninstall any remains from the previous failed STAP install attempt, and reboot the server)



Workaround:
Install directly on the server (STAP manual installation) instead of installing via GIM. Click on Cancel when prompted to find vcredist.msi file and continue with the rest of the prompts until product is installed.
Note: If you use this option, the STAP cannot be controlled via GIM.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006395