IBM Support

Changing the Requested Delivery Date is not updating the Inventory Supply table for ShipByDate for a purchase order in Sterling Order Management

Troubleshooting


Problem

Attempts to change the Requested Delivery Date does not update the Inventory Supply table for ShipByDate of the purchase order in IBM Sterling Order Management

Symptom

Steps to reproduce:

  1. Create an item with TagControlFlag="Y" and TimeSensitive="Y".


  2. Change the system date to a past date. Create a PO for this item. Schedule & Release the PO.


  3. Change the system date to a future date. So Requested Delivery Date on the PO line is in past.


  4. Change the Requested Delivery Date on the PO line.

In Application Console, PO line date is updated. But the SHIP_BY_DATE in YFS_INVENTORY_SUPPLY is not updated.

Cause

Post schedule system will not do any inventory/schedule update for change in PO requested delivery date.

Diagnosing The Problem

There are purchase order (PO) supplies in released status in the system which have a past delivery date. As a result, they won't come up in findInventory Api output. Even if the Requested Delivery Date is modified on the PO line, SHIP_BY_DATE in YFS_INVENTORY_SUPPLY table is not updated. So such supplies can't be used to promise the orders.

It works for PO in created status but not for PO in released status.

Resolving The Problem

Steps to resolve:

  1. Un-schedule the purchase order


  2. Make changes in PO line requested delivery date


  3. Re-schedule the PO

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006073