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In Change Style functionality, getFulfillmentOptionsForLines API is called for draft order but not for non-draft order

Troubleshooting


Problem

Attempts to update style functionality does not call getFulfillmentOptionsForLines API for non draft order in IBM Call Center for Commerce.

Symptom

Steps to reproduce:

For Draft Order:

  1. In Sterling Business Center, create a model item (e.g. Modelitem1) with 2 variations (e.g. Varitem1, Varitem2)

  2. Login to RCP COM

  3. Create a new order. Add an item (e.g. Varitem2).

  4. Choose Fulfillment Method 'Pick' and choose a store.

  5. Click on Change Style hyper link and select another item (e.g. Varitem1).

  6. In Change Style pop up, click on Add to Order button.

  7. Enable COM logs (e.g. CTRL+F2).

  8. Click on Update Order button. Check logs.

Actual Result: The getFulfillmentOptionsForLines API is called.

For Non-draft Order:
  1. Open an order in created status.
    e.g. One can complete the create order flow in scenario (A) above & use the same.

  2. Click on Add Lines to Order or Change Item Style task.

  3. Add an item (e.g. Varitem1).

  4. Choose Fulfillment Method 'Pick' and choose a store.

  5. Click on Change Style hyper link and select another item (e.g. Varitem2).

  6. In Change Style pop up, click on Add to Order button.

  7. Enable COM logs (e.g. CTRL+F2).

  8. Click on Update Order button. Check logs.

Actual Result: The getFulfillmentOptionsForLines API is not called.

Cause

This is working as designed.

Diagnosing The Problem

In Draft Order flow even after Update Order call, you are allowed to modify the Fulfillment Method and hence product calls getFulfillmentOptionsForLines API. But in case of Non-draft order Order after Update Order call, you are not allowed to change the Fulfillment Method and hence the getFulfillmentOptionsForLines API will not be called.

For example:
After clicking on Update Order button, for:

  • Draft Order: After selecting the draft order line, the Fulfillment Method options e.g. Pick Up, Shipping are enabled.


  • Non-Draft Order: After selecting the newly added order line, the Fulfillment Method options e.g. Pick Up, Shipping are disabled.

Resolving The Problem

As per product design, Call Center for Commerce call APIs only when it is required considering the performance of the application.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006035