IBM Support

Configuration of Cognos gateway on IIS displays a blank screen

Troubleshooting


Problem

Configuration of Cognos gateway on IIS not working. The browser dispalys a blank screen

Cause

Incorrect version and configuration of web.config

Environment

Cognos App Tier and Content Manager on Linux and Gateway on Windows

IIS- webserver

Diagnosing The Problem

Verified all the web.config files and found that the incorrect one was updated.

Checked cmplst.txt and found that Gateway was running R5 and the APP Tier+CM was running R6

Resolving The Problem


In Cognos Analytics the web.config file can reside in 3 locations.
install_location\cgi-bin\web.config
install_location\webcontent\web.config
install_location\webcontent\bi\web.config - This is the one we need to be updated correctly

Steps:
Uninstall R5 of the Gateway only
Reinstall R6 Gateway component
Reconfigure Cognos Gateway on IIS as per Technote 2000097

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.6;11.0.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22006022