Troubleshooting
Problem
User launches Controller client. An error appears.
Symptom
ORA-12557: TNS:protocol adapter not loadable
Cause
Controller application server's Oracle client environment has not been configured correctly.
- In one real-life example, the problem was triggered by having a system variable 'ORACLE_HOME' defined (on the Controller application server). This is unnecessary for most environments.
Example:
In one real-life example, there was a system variable 'ORACLE_HOME' defined:
Resolving The Problem
Make sure that all the Oracle-client-related configuration (on the Controller application server) is correct.
Steps
To delete the 'ORACLE_HOME' system variable, perform the following steps:
1. Logon to the Controller application server as a Windows administrator
2. Right-click on 'My Computer' and choose 'Properties'
3. Click "Advanced System Settings"
4. Click "Environment Variables"
5. Inside the "System Variables" section, look for an entry for 'ORACLE_HOME'
6. Delete this entry
7. Restart the Controller application server
8. Test.
- For most environments, there is no need to have a 'ORACLE_HOME' system variable.
Steps
To delete the 'ORACLE_HOME' system variable, perform the following steps:
1. Logon to the Controller application server as a Windows administrator
2. Right-click on 'My Computer' and choose 'Properties'
3. Click "Advanced System Settings"
4. Click "Environment Variables"
5. Inside the "System Variables" section, look for an entry for 'ORACLE_HOME'
6. Delete this entry
7. Restart the Controller application server
8. Test.
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
03 December 2019
UID
swg22005676