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Cognos Analytics 11 returns error: Cannot open object report

Troubleshooting


Problem

Cognos Analytics 11 with a Content Manager installation/configuration launches the portal but reports cannot be interactively executed. When running a report interactively the following error is returned: Cannot open object report Another symptom is that the Report Perspective cannot be launched because the New [+] -> Report button is missing. You will see the same symptoms if trying to connect directly to the CM URI directly.

Symptom

Cause

When configuring the webserver the Content Manager Host/Port was used in the Reverse Proxy or BalanceMember settings instead of the Application Server.

Environment

Resolving The Problem

In the Reverse Proxy settings for IIS or BalanceMember for Apache/IHS ensure that the entry points to the Application Server and not the Content Manager.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22005404