Question & Answer
Question
How do I modify a Role Name and the associated Role's In-basket Name in IBM Case Manager Client?
Cause
When I change a Role Name and the Role's In-basket Name in IBM Case Builder, the change is not getting deployed to IBM Case Manager Client.
Answer
To modify a Role Name and the associated In-basket Name, you must do the following:
1) Do the Role "Name" field modification in the Case Builder "Roles" tab
2) Do the "In-basket Name" field modification in the "In-baskets" tab
3) Deploy the Solution
2) Using Case Client, go into "Manage Roles" and add the required users/groups to the newly modified Role
3) Remove the users/groups from the original (unmodified) Role
4) The modified Role is now available and the original (unmodified) Role is removed from Case Client
Clean Up:
To completely remove the original (unmodified) Role and In-Basket, do the following:
1) Open PCC
2) Go to Application Spaces, and remove the unwanted Role
3) Go into the Work Queues and remove the unwanted In-basket from the "In-baskets" tab
4) Commit the changes
Example Instructions:
As an example, the screen shot shows a Role called "CSR" , which has three in-flight workitems:
1) Using Case Manager, modify the Role name and the associated Role In-basket (as described above)
2) Deploy the Solution and exit Case Builder
3) Logon to Case Client as a Case administrator
4) Go into "Manage Roles" and you should see the original and the modified Roles. In this example, both the CSR and CSR-MODIFIED Roles are seen in this screen shot:
5) Remove users from the original Role (CSR) and add the users to the new, modified Role (CSR-MODIFIED).
6) Save the change
7) In Case Client, you will be able to select the newly modified Role:
8) Once selected, the In-basket name will show the modified name (CSR-MOD in the example):
To clean up the now unused Role (CSR), follow the "Clean Up" steps provided above.
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Document Information
Modified date:
17 June 2018
UID
swg22005247