IBM Support

Unable to access the IBM Sterling Business Center application

Troubleshooting


Problem

Unable to login to IBM Sterling Business Center(SBC) application

Cause

There are security Fix Packs provided on each product version which deliver new struts jar.

Diagnosing The Problem

The below error is seen in the SystemOut logs:
[6/15/17 10:21:12:415 EDT] 0000003d webapp E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [ServletError]-[com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor]:
Unable to find interceptor class referenced by ref-name actionMappingParams - interceptor-ref - wsjar:file:/opt/IBM/WebSphere/AppServer/profiles/Default/installedApps/L055-OMDMGR-1QVCell02/Sterling-Perf.ear/sbc.war/WEB-INF/lib/platform_afc_ui_impl_ui.jar!/scuiimpl_struts.xml:29:50
at
com.opensymphony.xwork2.config.providers.InterceptorBuilder.constructInterceptorReference(InterceptorBuilder.java:50)

The error says "Unable to find interceptor class referenced by ref-name actionMappingParams". The interceptor class should be a part of struts jar delivered with the product.

Resolving The Problem

Install the applicable security Fix Packs(FPs) for your product version from Fix Central.
Note that Security FPs are not cumulative, they need to be applied one by one. Please refer to the Security_Fix_Pack_Installation.txt present in the downloaded FP zip for Minimum Requirements.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.3;9.2.1;9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22004954