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ScheduleOrder locks database tables even when Node Capacity Availability is more than Threshold configured

Question & Answer


Question

Why doesScheduleOrder locks database tables even when Node Capacity Availability is more than threshold configured in IBM Sterling Order Management?

Cause

Locking of table is still happening even after setting the nodecapacity parameters.

Answer

On Capacity update product will always lock based on resource pool and date. Product avoids locking based on the Node Capacity Availability property configuration on capacity availability calculation. A sample of the property configuration is provided below:

yfs.nodecapacity.lock = Y
yfs.nodecapacity.threshold = 1
yfs.nodecapacity.timeout = 5

During scheduling product computes capacity availability and then when final decision is made, it updates capacity consumption. Here, during availability calculation, product will determine whether to lock / not lock (obviously depending on property settings) and then when capacity is updated, it locks consumption table(YFS_RES_POOL_CAPCTY_CONSMPTN) for update.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Maintenance","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22004445