IBM Support

No Traffic from Cloudera Hadoop Cluster

Troubleshooting


Problem

You have configured STAP per the guidelines to monitor a Cloudera Hadoop cluster. No data is being logged.

Symptom

No data logged

Cause

No Kafka broker found

Diagnosing The Problem

In syslog you will see this message each time STAP is restarted:
KafkaTopicWorker(): exception: KafkaTopicStatus::getBrokerById(): broker not found

Resolving The Problem

1. In the STAP installation directory you will see a file named '.<kafka_topic_name>_status' (where <kafka_topic_name> is defined in the guard_tap.ini parameter 'kafka_topic_name='). Check that the value is correct. If no, edit to use the correct value and restart the STAP process.

If yes, proceed to step 2.

2. Rename, deleted or move the .<kafka_topic_name>_status file and restart the STAP process.

Deleting or moving this file will force STAP to to query the kafka brokers for the status of the cluster again.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.2","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22003691