IBM Support

Schedule order picks up all STORE orderlines for processing in Sterling Order Management

Troubleshooting


Problem

Attempts to run ScheduleOrder picks up all STORE ordrelines for processing in IBM Sterling Order Management.

Symptom

The order comprises of line Type – INLINE and STORE Lines.
In an order, there are orderlines of type INLINE and STORE. Only the INLINE Type are scheduled as per pipeline configuration. These STORE orderlines are picked up by OOB scheduled transaction along with the INLINE orderlines for processing.

Cause

This is working as designed.

Diagnosing The Problem

The orderlines are picked up for graph creation and not processing.

Resolving The Problem

Processing and creating an order graph are two different things. Order graph includes all lines. This is how scheduling/order knows which lines depends on what. This is done to identify dependencies (like service lines or dependent lines or bundle lines). Graph creation is required for the order and cannot be avoided. Actual processing is done only for the lines pickable by the transaction. If you look to "before entering solver", you'll only see the lines being processed. Here, you'll see only INLINE order lines

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg22002881