Troubleshooting
Problem
When trying to attach to a LDAP directory Server using the test functionality in Cognos Configuration, an error message is displayed and the connection fails. This occurs for LDAP and LDAPS (LDAP via SSL).
Symptom
CAM-AAA-0146 The namespace 'xxx' uid is not available. CAM-AAA-0064 The function 'CAM_AAA_Configure' failed. CAM-AAA-0056 Unable to authenticate. CAM-AAA-0064 The function 'LDAPHandlePool::Get()' failed. CAM-AAA-0026 The function call to 'ldap_simple_bind_s' failed with error code: '81' Can't contact LDAP server
Cause
The code trying to contact the LDAP server on the configured host and port received a response
but it wasn't one which was expected.
Possible causes are (as known so far)
- talking SSL/LDAPS to a non-SSL/LDAP socket or vise versa
- errors thrown by firewalls, routers or bridges
i.e. while trying to reach the host:port some error occurred - permission issues
i.e. some firewall rejected the request with some http error page - SSL handshake failed
i.e. the certificate from the server and the ones configured for the namespace
don't match up.
Resolving The Problem
- Check that the port you are using is set up for the correct protocol, i.e. if you want
to use SSL make sure the port is actually a SSL port. Same for non-SSL of course. - ensure there is no firewall blocking/denying access
- ensure Namespace is correctly configured for LDAPS
- to check the port is running LDAP(S) use a third party LDAP tool or even a browser.
Another possibility is to use OpenSSL. - to check for firewall blocking use a
browser, ping to verify the host is reachable and telnet to the port
(telnet <host> <port>) to check if the request goes through.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg22002783