IBM Support

Cannot test datasource connection to secured powercube on a network share: PDS-PCT-0020 PDS-REC-0021

Troubleshooting


Problem

Unable to test a datasource connection to a secured powercube located on a network share. The same cube works if located on the same computer.

Symptom

PDS-PCT-0020 Unable to open the PowerCube:
PDS-REC-0021 (Open Data Cache). Cube path/name may be incorrect; cube may be corrupt or may not be a PowerCube.

Cause

By default, the Cognos service is started with the "Local System" account which is unable to access network resources.

Resolving The Problem

Change the Cognos service to start with a named user account that has the appropriate permissions on the shared drive.

Appropriate permissions would be a user that has administrator rights on the Cognos server. If you continue to experience this error, please contact IBM Cognos Customer Support for further assistance.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22002511