IBM Support

How to Troubleshoot a Planning Analytics TM1 Server Crash

Troubleshooting


Problem

Planning Analytics TM1 Server crash

Cause

If you encounter a TM1 Server crash - this means that the TM1 Server had been shut down unexpectedly. When this occurs, the tm1sd.exe process has shut down – leaving no clues behind in the TM1Server log.  A crash by nature, means that an unhandled exception has occurred. The problem can stem from the application, or potentially caused by a resource issue on the server the application is running on. 
When a crash occurs, we want to determine the cause of the crash so that we can ensure the problem does not happen again.  By default, logging alone is not sufficient enough to determine the cause, as the exception is unhandled to begin with. The steps in this document cover the collection of details required by IBM Support to better understand and diagnose the cause of a crash.
NOTE: There are a few scenarios (such as being unable to write to the TM1 Transaction log), where the TM1 Server will self-terminate in order to preserve the integrity of the data.  In such scenarios, a FATAL error is recorded in the tm1server.log file.  

Resolving The Problem

In the event of a TM1 Server Crash, the following should be collected:
  1. The exact version of the TM1 Server
  2. Basic description of the problem
    • What kind of activity leads up to the problem?
    • Are there any server-related problems in Event Viewer?
    • Can the problem be re-created on demand?
      • This may not always be available. Sometimes there is too much activity on the server to know which action triggered the crash – or that users were simply working as they normally do, when the problem occurred.
      • Although difficult, anything we can do to better understand the steps or activity leading to the crash will allow us to more easily identify the cause/solution.
  3. Windows Error Reporting (WER) Crash DMP of the tm1sd.exe process (Full Dump)
  4. tm1server.log(s)
    • Location defined in the affected server's tm1s.cfg file
    • Must include the timeframe the problem occurred
  5. tm1top.log(s)
    • See: https://www.ibm.com/docs/en/planning-analytics/2.0.0?topic=logs-tm1-top-log
    • or: https://www.ibm.com/support/pages/how-enable-tm1top-logging-using-tm1topini-file
  6. tm1s.cfg
    • Typically resides in or near the TM1 Data directory

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Document Information

Modified date:
03 May 2022

UID

swg22002278