IBM Support

Routing Guide Details screen issue on application manager in Sterling Order Management

Troubleshooting


Problem

Attempt to view carrier service code does not return the description when you select a carrier in IBM Sterling Order Management

Symptom

Go to In the Application Manager-Logistics Management-Shipment Planning
The requested carrier service code field does not return the description when you select a carrier.

Cause

Maximum number of records that can be displayed in the drop down is 75. This is the Default behavior of the Product and cannot be changed.

Diagnosing The Problem

This issue is seen when you have more than 75 carriers configured and when you select a carrier which greater than the 75th record. From 76th record onwards you are able to only select the record but not able to save it. On saving it is not displayed on the screen. However in the database it is getting updated properly in the table and column - yfs_routing_guide_detail.input_carrier_service_code.

Resolving The Problem

Workaround:

If the number of records is more than 75, setting the yfs.yfs.config.lookuplimit property in the customer_overrides.properties file to more than the total no of records will resolve the issue of the look-up.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22002223