IBM Support

IBM Guardium Security: Domain for Datasource not Found in V10

Troubleshooting


Problem

You are trying to create a report or query for datasources based on the Guardium built-in datasources report. But you no longer see this domain in the Query Builder.

Cause

It has been moved from V9.

Environment

v10

Resolving The Problem

In v9, the datasource entity was available in Query Finder for a Vulnerability Assessment or a Classification (these are the related domains).

In v10, it has been moved to the "CAS Config" Domain (Configuration Auditing System).
The user must have the admin or cas role assigned to see this domain.

In Reports > Report Configuration Tool > Query Builder, select the Domain > "CAS Config".
Under Entity > Datasource, click New > give the query a name, and select the Datasource Entity.
The datasource attributes are now available to create a report.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0;10.0.1;10.1;10.1.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22001969