IBM Support

Guardium GIM module fails to install with error "Failed installing UTILS"

Troubleshooting


Problem

GIM install fails with the following error messages: ./guard-bundle-GIM-10.0.0_r79963_trunk_1-suse-11-linux-x86_64.gim.sh -- --dir /opt/ibm/guardium/ --sqlguardip 10.2.3.4 --tapip 10.2.3.5 Verifying archive integrity... All good. Uncompressing Guard BUNDLE-GIM Installer.... perl used : /usr/bin/perl This product is subject to the license terms associated with the IBM Security Guardium product purchased. Installing modules .... Failed installing UTILS Installation failed

Cause

This error is caused when the GIM cannot communicate with the Guardium appliance during installation.

Resolving The Problem

Here are the following ways to resolve this issue:

1. Check that the GIM process has installed (e.g. "ps -ef | grep gim" in linux). Sometimes the GIM process can install in the background successfully even with this error message

2. Check the ports 8081, 8081, 8444, 8445, 8446 are open bi-directionally on any firewalls between Server and Guardium appliance. Then try the install again.

3. Run the install in "listener mode" by running the install again without specifying the "--sqlguard_ip <IP>" parameter. For example replace the command:

./guard-bundle-GIM-10.0.0_r79963_trunk_1-suse-11-linux-x86_64.gim.sh -- --dir /opt/ibm/guardium/ --sqlguardip 10.2.3.4 --tapip 10.2.3.5



with:
./guard-bundle-GIM-10.0.0_r79963_trunk_1-suse-11-linux-x86_64.gim.sh -- --dir /opt/ibm/guardium/ --tapip 10.2.3.5

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0;10.0.1;10.1;10.1.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22001870