IBM Support

IBM Security Guardium: Agents Not Started After Reboot but will Start Manually

Troubleshooting


Problem

You reboot the database server where the Guardium agents (e.g. GIM, STAP) are installed, and they are not started. Only KTAP is loaded. However, they can always be started manually.

Cause

The start-up procedure (Upstart or inittab) has tried starting Guardium before the file system was mounted.

Environment

Any environment that does not have Guardium installed on the internal disk drives.

Resolving The Problem

As a work around, you can:

  • Change the system startup sequence at the system level to ensure the Guardium applications are mounted before the startup procedures are invoked. If you cannot have Guardium installed on internal disk drives, this is the best option.
  • Try editing the etc/fstab so the mount point where Guardium is installed is the highest application in the list.
  • Add a sleep statement or other delay to the Guardium .conf files as a short term solution.
    Note: this option introduces software management issues and is the least desirable option.
  • Guardium Development is planning to make changes to the startup scripts to detect whether the file system is accessible. This is expected during the 10.5 time frame.

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Document Information

Modified date:
16 June 2018

UID

swg21993847