Troubleshooting
Problem
Symptom
Cause
Diagnosing The Problem
2. Check for aggregation errors around import/export on the aggregator and collectors - How to troubleshoot Guardium aggregation or archive errors. If the data has not imported correctly on the aggregator it may cause this problem.
3. Does the exact same report run on the collector have data?
4. In the case when Client/Server report has no data, does a report with Session as the main entity, with only session attributes, have data?
5. In the case when Object, Command, or Field report has no data, does a report with SQL as the main entity, with only SQL attributes, have data?
If answer to 3 and 4 or 5 is yes, this technote is likely to apply to your case.
Resolving The Problem
2. By default, not all static data is exported from the collector to the aggregator every day. To force the collectors to export all the static data on the next export:
i) Run in the CLI of all collectors exporting to the aggregator:
- store next_export_static on
3. If the problem is not resolved by these steps it may require root access by Guardium support to proceed further. Support engineers can use the information in internal section of this technote. Please collect the following information before opening a PMR:
i) In the aggregator CLI run:
- aggregator debug start
iii) In the aggregator CLI run:
- aggregator debug stop
- support must_gather agg_issues from aggregator and one collector.
- agg_debug.log from the aggregator fileserver.
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Document Information
Modified date:
03 February 2021
UID
swg21993824