IBM Support

IBM Guardium Security: Cannot Start GIM Due to Unrecognized Characters

Troubleshooting


Problem

You are starting the Guardium Installation Manager Service (GIM) and it fails. The GIM.LOG states there is an unrecognized character at ...WINSTAP/current/conf.

Cause

There is BOM (binary order mark) data in either the GIM or STAP conf file. These characters can be seen with a binary editor.

Environment

Windows

Diagnosing The Problem

Here is an example of the message in the GIM Log:


16:32:48, Tue Oct 18, 2016 : -I- GIM client started (Tue Oct 18 16:32:48 2016)
...
16:32:48, Tue Oct 18, 2016 : -I- temp_dir=c:\windows\temp
16:32:48, Tue Oct 18, 2016 : -I- Initializing GIM parameters
16:32:48, Tue Oct 18, 2016 : -I- Executing 'status' GIM (C:/Program Files (x86)/Guardium/GIM/GIM/current/rc status by_gim)
16:32:48, Tue Oct 18, 2016 : -E- Failed getting params from C:/Program Files (x86)/Guardium/GIM/WINSTAP/current/conf (Unrecognized character \xEF; marked by <-- HERE after my <-- HERE near column 4 at (eval 28) line 1. )
16:32:48, Tue Oct 18, 2016 : -I- GIM client started (Tue Oct 18 16:32:48 2016)
...

Resolving The Problem

Remove the problem characters:

1. Open the file in an editor like Notepad++.
2. Use Encoding > Convert to UTF-8 without BOM
3. Save (Ctrl+S).

If you reopen the file in a binary editor, those characters are gone.

Restart the GIM service and it should start without the error.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21993376