IBM Support

Guardium v10 audit process results can not be viewed - "You do not have privileges to see this report"

Troubleshooting


Problem

I have set up a user to view audit process results. The user has a role with permissions to audit process to-do list and report builder. When viewing results on the to-do list the user sees an error "You do not have privileges to see this report"

Cause

Audit process builder privileges are required to view audit process results

Diagnosing The Problem

For the user with the problem, check their role from GUI accessmgr account -> User browser

In "Role Browser" check the permissions on that role. If the role does not have audit process builder permissions it will result in this error.

Resolving The Problem

To add a user that can see the audit results, but does not have access to the audit process builder. Edit the role so it has privileges for audit process builder, but it is not visible on the GUI.

1. Edit the role and add audit process builder privileges

2. Edit the layout for the role and remove audit process builder

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Appliances","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"10.0;10.0.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21992906