IBM Support

Organization not visible in Enterprise dropdown in IBM Sterling Business Center

Question & Answer


Question

The enterprise dropdown on top right of the home screen in IBM Sterling Business Center(SBC) is not showing all the organizations even though they are present in the database.

Cause

The API call to fetch the enterprises looks up only upto 5000 records at a time. This meets the set up for most of our customers. In case a customer has more than 5000 enterprises set up in their implementation they might run into this problem.

Answer

1. Use yfs.yantra.app.maxrecords=<number of records> to increase the number of records
2. Extend the mashup xml and overrride the mashup with the id
"sbcPostLogin_getOrganizationList". In this extended mashup you can add
the attribute MaximumRecords in the element <Organization/>.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21992434