IBM Support

Cognos Analysis For Excel (CAFE): Error Occurs When Selecting The Option To Create A Crosstab

Troubleshooting


Problem

The following error occurs in CAFE when selecting the option tab to create a crosstab report. The error occurs for one machine only

Symptom

IBM Cognos For Microsoft Office
Invalid index. (Exception from HRESULT: 0x8002000B (DISP_E_BADINDEX)

OK Details

Cause

The error is due to enabled addins within Excel since it is only one user affected.

Resolving The Problem

STEPS:
1. Launch Microsoft Excel
2. Select File>Options
3. Select Add-ins
4. At bottom, ensure that 'Manage' is set to 'Excel Add-ins', and then click 'Go
5. Make sure only IBM Cognos Office Reporting BI and TM1 addins are enabled.
If any other addins are enabled uncheck them all.
(Make note of which Addins are enabled before disabling as they will be added back later)
6. Close and re-open Excel and test creating a crosstab and confirm no further error.
7. If no further error, re-add the addins that were disabled above and confirm no further errors.

[{"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Planning Analytics","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21992378