IBM Support

Client IP Does not Match Hostname in Guardium Reports

Troubleshooting


Problem

In an IBM Security Guardium report the client IP does not match the client hostname for the connection. The client IP and server IP match and the connection is to a MSSQL server. This is working as designed, the connection is using NAMED PIPES protocol, not TCP.

Symptom

Client IP matches serverIP in the report, not the client hostname. DB is MSSQL server.

Cause

Working as designed. The NAMED PIPES protocol includes the client hostname but not the client IP so we use the server's IP as in local connections.

Environment

This applies to all versions of Guardium and any MSSQL server.

Resolving The Problem

Working as designed. If you are not sure, add the protocol field to the report. The value should be WINDOWS NAMED PIPES.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.0;10.0.1;10.1;8.2;9.0;9.1;9.5","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21992065