IBM Support

Guardium Error "You do not have privileges to see this Report" when viewing GUI report as non admin user

Troubleshooting


Problem

Error message "You do not have privileges to see this Report" when you try and view a GUI report as a non admin user.

Symptom

Screenshot of the error:

Cause

The above error is caused when the Report does not have the correct privileges for the user viewing it.

Resolving The Problem

From the Non-Admin user:

1. Go to Monitor/Audit > Build Reports > Report Builder and search for the report name
2. Select the report and click on the Roles button
3. Select the required roles and click Apply
4. You will now be able to see the report in the GUI


From the Admin user:

1. Go to Tools > Report Builder > Find the Query
2. Select the Roles button, check the box next to the required roles, and click apply
3. If there is a report created from this query, repeat steps 1 and 2 for the Report. Alternatively create a new report as the non-admin user, and make sure the permissions are correct

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21991864