Question & Answer
Question
Why is my Archive or Backup to TSM from IBM Security Guardium not working? And how do I know what the error is and how to fix it?
Cause
When facing any issues with TSM there are usually TSM error messages which help identify the issue. There are several places to look for these sort of TSM errors.
1) There may be an error out putted to the gui or in the cli.
2) Check the Aggregation/Archive Log report in the gui under the Guardium Monitor tab
3) use this cli command and specify 3 at the prompt for example ( for 3 minutes ) and then reproduce issue during this time
- support must_gather app_issues
This operation may take several minutes to complete.
Please enter numeric value for debugger's timeout in minutes (no more than 1440) or 0 to stop debugger.
3
.
Answer
Please refer to the linked technotes for each error message. This list is not exhaustive but covers most commonly seen errors.
A) ANS1398E Initialization functions cannot open one of the Tivoli Storage Manager logs or a related file: /opt/tivoli/tsm/client/ba/dsmerror.log. errno = 13, Permission denied
Failed to Send a Test File to the TSM destination
B) ANS2036W Pruning functions cannot open one of the Tivoli Storage Manager prune files: /var/guardium/jakarta- tomcat-4.1.30/dsmprune.log. errno = 13, Permission denied
File transfer to TSM server has an error
C) ANS0361I DIAG: TCP/IP SO_SNDBUF value 256 specified as TCPWINDOWSIZE is not supported by OS. It is set to the allowed size -244. (The error is informational only)
D) ANS1219E: A virtual node name must not equal either a node name or the system host name
ANS1219E: A virtual node name must not equal either a node name or the system host name.
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Document Information
Modified date:
12 December 2019
UID
swg21991623