IBM Support

Cognos Mobile native app cannot connect to an environment configured with redirects on the web server

Troubleshooting


Problem

1) The app is unable to connect to the server and just spins without ever coming back. 2) Or when the app is set to Pass-through authentication, the Cognos UI appears inside the dialog box.

Cause

The app expects a direct response from the web / authentication server. If the web server is designed to redirect the user to another address where they have to perform another action, the app will not be able to connect. The app expects a Pass / Fail answer, not another web page.

Environment

This applies to all versions of the Cognos server. (v10.1.1 to v11)

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21991533