IBM Support

Guardium "Database Name" field empty in reports for Oracle database traffic

Troubleshooting


Problem

When viewing reports, the Database Name field contains values for some traffic but not all traffic to an Oracle database.

Cause

This can be caused by the following issues:

1. The configuration is incorrect. If the values for DB User Name or Source Program are also empty - per this technote :-
 2. Missing packets caused by missing login. Please ensure that there are no sniffer performance issues per this technote :-
3. Blank Database name is expected behaviour depending on the connection to the database. per this technote :-

Resolving The Problem

Database Name is not expected to be populated for all Oracle traffic. This field is populated depending on how the connection is made to the database.

During the connection to an Oracle database the parameter Service Name is always expected to be populated that identifies the Service that the Client has connected to. However Database Name is not always contained in the login packet so does not appear in Guardium.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0;10.0.1;10.1;10.1.2;10.1.3;9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
13 May 2020

UID

swg21991361