IBM Support

IBM Security Guardium - Data Import fails with "internal database of the appliance is almost full" message even though there's enough database and disk space

Troubleshooting


Problem

Data Import fails with error []internal database of the appliance is almost full[] message even though there's enough database and disk space.

Cause

The appliance had space issues in the recent past causing the system services (especially nanny) to go down automatically. The space issue was resolved but all the system services were not brought up, making the aggregation process think that the system is still close to its limit of disk or database usage.

Diagnosing The Problem

1. Make sure that there are no issues as far as DB usage OR disk usage is concerned.

Check DB Usage : support show db-status used %

For more details, refer to What can I do if I see my Guardium Appliance getting full?

2. Do a "run once now" for Data Import from the GUI. The Aggregation/Archive Debug Log displays an error internal database of the appliance is almost full for failed data import.

Resolving The Problem

Execute below command as user cli on the affected aggregator appliance :

restart stopped_services



And then do a "Run once now" for Data Import.

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[{"code":"a8m0z000000Gp0LAAS","label":"AGGREGATION"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0.1;11.0.0"}]

Document Information

Modified date:
28 October 2020

UID

swg21991347