IBM Support

Guardium STAP becomes red in GUI soon after install

Troubleshooting


Problem

STAP appears green in the Guardium Collector's GUI after install, but as soon as any actions are taken (such as restart, or Inspection Engine configuration) the STAP goes red and cannot be started.

Symptom

You may see the following errors in the server syslog:

Apr 11 12:00:23 <hostname> guard_tap[6695]: GUARD-01: Error Initializing STap The parameter kafka_bootstrap_servers in section TAP cannot be converted.
Apr 11 12:00:33 <hostname> guard_tap[7194]: Tap_controller::init failed The parameter kafka_bootstrap_servers in section TAP cannot be converted.

Cause

The group "guardium" has been removed from the server's group permissions configuration.
This can be caused by other software running on the server, that manages the groups.

Diagnosing The Problem

To verify this is the cause, please check the group definition "guardium" exists. For example on RedHat server this would be in the /etc/groups configuration file.

Resolving The Problem

After diagnosing this issue, if you find that the group "guardium" is missing from the server please identify why it was originally removed and restore it.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF002","label":"AIX"}],"Version":"9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21991304