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changeOrder API does not cancel entire order

Question & Answer


Question

Why does changeOrder API not cancel entire order when order line quantity is different from original quantity in

Cause

As per the product behavior changeOrder does not cancel the entire order if the order line and quantity is different from the one on the order because product allows to cancel only the specified quantity and order line combination.

Answer

changeOrder will cancel the entire Order if the cancel is passed at the order Header line without any order line details. It also cancels the entire order if the exact quantity is passed along with the
orderLine detail.

<Order Action="CANCEL" OrderHeaderKey="20160916161501118368">
</Order>


But if you pass the OrderLine and quantity details which is not equal to the one on the order line level, it will only cancel the required line and the quantity mentioned in the OrderLine tag.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2;9.2.1;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21990846