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Receiving the error message "Fault occurred while processing" when processing running IBM TRIRIGA web service runNamedQuery

Question & Answer


Question

Why am I receiving the error message "Fault occurred while processing" when processing running IBM TRIRIGA web service runNamedQuery?

Cause

Following the correct syntax and having a good query for being executed by runNamedQuery, but it keeps failing with no reason or clear error message on the log.

Answer

When using "IBM TRIRIGA Application Platform Version 3 Release 5.1 Connector for Business Applications Technical Specification" pages 74-75, the runNamedQuery Sample Request on a open source API testing tool for SOAP and REST APIs application (3rd party), you may have the following sample entered for being executed against IBM TRIRIGA application (http://:/ws/TririgaWS?wsdl)) :


<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:ws="http://ws.tririga.com" xmlns:dto="http://dto.ws.tririga.com">
<soap:Header/>
<soap:Body>
<ws:runNamedQuery>
<ws:moduleName>triRequest</ws:moduleName>
<ws:objectTypeName>triInspectionRequest</ws:objectTypeName>
<ws:queryName>triFundingRequest - Find - All Funding Requests</ws:queryName>
<ws:start>1</ws:start>
<ws:maximumResultCount>10</ws:maximumResultCount>
</ws:runNamedQuery>
</soap:Body>
</soap:Envelope>


This will not return any list of records (or none if Query returns no record), but it may return the following error message:


<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
<soap:Body>
<soap:Fault>
<soap:Code>
<soap:Value>soap:Receiver</soap:Value>
</soap:Code>
<soap:Reason>
<soap:Text xml:lang="en">Fault occurred while processing.</soap:Text>
</soap:Reason>
<soap:Detail>
<ns1:Exception xmlns:ns1="http://ws.tririga.com"/>
</soap:Detail>
</soap:Fault>
</soap:Body>
</soap:Envelope>


There will be no error printed out on the server.log file. This will be working for other IBM TRIRIGA SOAP binding entries (other than runNamedQuery). If you use a different query, that will not help as well.

You may have some inconsistency set up on the metadata records after an upgrade. For fixing this issue, simply open the Query you want to execute and save it. This will be forcing IBM TRIRIGA Platform to fix any inconsistency from background and you will be able to use runNamedQuery successfully for that specific query.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21990203