Question & Answer
Question
How do you import fulfilled orders, having re-ship orderlines, from an external system to IBM Sterling Order Management System?
Cause
The importOrder API does not expose fields necessary to import reship order lines.
Answer
A reship order line is a line that was spawned off from another order line on the same order. This is done if the customer did not get the original item due to a carrier delivery issue and as a result a reship line was created (using reshipOrderLines API) on the sales order and a new item/product was shipped to the customer.
Sterling OMS supports the ability to create a new reship line using the reshipOrderLines API and you use this when you want to add a reship line to an order in OMS. But, you need the ability to import an order from an external system using the import order API which already has a reship line.
There is no element to specify the reshipped line's relationship to orderline for importOrder API as of now.
Workaround:
Primary keys can be passed to import with reship line relationship. Pass OrderLinekey and ReshipParentLineKey in the input of importOrder API.
For example:
<Order ..... >
<OrderLines>
<OrderLine OrderLineKey="OrderLineKey1" ....>
.....
</OrderLine>
<OrderLine OrderLineKey="OrderLineKey2" ReshipParentLineKey="OrderLineKey1" ....>
.....
</OrderLine>
......
</Order>
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Document Information
Modified date:
16 June 2018
UID
swg21989564