IBM Support

Cannot change format of report from Cognos Viewer - IBM Control Center

Troubleshooting


Problem

When you try to view a report sent to IE11 browser in a different format like PDF, nothing is returned but a blank window. When you use the email option an error DPR-ERR-2079 is returned in a pop-up window from Cognos.

Symptom

DPR-ERR-2101 Your request was invalid' error when changing Standard Report
DPR-ERR-2079 Firewall Security Rejection. Your request was rejected by the security firewall.

Cause

IBM Control Center was configured with a short host name in configCC instead of the fully qualified Host domain name.

Environment

Internet Explorer 11 Browser (IE11)

Diagnosing The Problem

Review the URL returned when a report is run for a short host name.

Resolving The Problem

Run configCC and enter the fully qualified Host domain name in the WebSphere Liberty Profile.

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.1.0.1;6.1;6.0.0.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21989416