IBM Support

Unable to install the IBM Sterling OMS product in the same install location as that of the earlier installation

Question & Answer


Question

How do you install IBM Sterling Order Management System (OMS) in same install location as that of the earlier one on same machine using IBM Installation Manager ?

Cause

You get a error during installation stating that the product is already installed.

Answer

If you want to install the new instance in the same folder hierarchy as that of the original one. then IM does not allow it, because it has the entry in it's configuration files for earlier installation locations and hence it throws error.

To resolve, you need to modify the below mentioned configurations file of Installation Manager for removing the entry for earlier non-required OMS installation details, after taking a backup of the mentioned configuration files :

  • installRegistry.xml

  • installed.xml


Located at :
  • /var/ibm/InstallationManager/ On Linux .


  • C:\Documents and Settings\All Users\Application Data\IBM\InstallationManager\ On Microsoft Windows XP, Windows 2000 and Windows 2003.


  • C:\ProgramData\IBM\Installation Manager\ On Microsoft Windows Vista.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.3;9.2.1;9.2;9.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21987912