IBM Support

nzstart fails with message :sudo: must be setuid root nzstart: Error: SSH configuration unsuccessful on IBM PureData for System Analytics

Troubleshooting


Problem

nzstart fails with error message of sudo: must be setuid root nzstart: Error: SSH configuration unsuccessful

Symptom

NPS system will not start database operations. nzstart fails straight away with error message.

Cause

/usr/bin/sudo permissions have been changed. Sticky bit turned off

Environment

Netezza appliance

Diagnosing The Problem

 
[nz@nzhost1 ~]$ nzstart -i sudo: must be setuid root 
nzstart: Error:
SSH configuration unsuccessful

Resolving The Problem

Check /usr/bin/sudo file permissions..

[root@nzhost1 ~]# ls -ltra /usr/bin/sudo
---x--x--x 2 root root 186648 Sep 20 2012 /usr/bin/sudo

The permissions should be with sticky bit enabled.. as below...

[root@nzhost11 ~]# ls -ltra /usr/bin/sudo
---s--x--x 2 root root 186648 Sep 20 2012 /usr/bin/sudo


To correct the problem set the sticky bit ...

[root@nzhost1 ~]# chmod u+s /usr/bin/sudo

[root@nzhost11 ~]# ls -ltra /usr/bin/sudo
---s--x--x 2 root root 186648 Sep 20 2012 /usr/bin/sudo

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSULQD","label":"IBM PureData System"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0"},{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSUSQ8","label":"IBM Netezza Analytics"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
03 June 2022

UID

swg21987791