IBM Support

Improper display of Pickup Date in where is my shipment screen

Troubleshooting


Problem

Attempts to update the pickup date on an order does not reflect the updated date in where in my shipment screen in IBM Sterling Call Center for Commerce.

Symptom

Steps to replicate:

  1. Create the order for pickup in CCC.

  2. Use following changeOrder input to change the pickup date
    ----------------------
    <Order EnterpriseCode="Matrix-R" OrderHeaderKey="2016071911442453393"
    ReqDeliveryDate="2016-07-21T00:00:00-07:00">
       <OrderLines>
           <OrderLine DeliveryMethod="PICK" IsBundleParent="N"
               OrderLineKey="2016071911450053400" PrimeLineNo="1"
               ReqShipDate="2016-07-26" ShipNode="Mtrx_Store_1">
           </OrderLine>
       </OrderLines>
    </Order>

    ----------------------

    changeOrder input template (ChangefulfillmentOptions) has ReqDeliveryDate attribute at the header level
  3. Schedule the order date shows the older date.

Cause

As you are passing that ReqDeliveryDate value in the changeOrder input template, system is stamping that date in the order line schedule .

Resolving The Problem

To resolve, please remove the ReqDeliveryDate attribute from changeOrder input template.

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Document Information

Modified date:
11 February 2020

UID

swg21987654