Troubleshooting
Problem
Attempts to create an item with infinite inventory shows item as out of stock in IBM Call Center for Commerce.
Cause
Since there is no explicit inventory adjustment, no entries are made in the yfs_inventory_item table as a result of which no alerts are published by RTAM.
Diagnosing The Problem
The out of the box mashup for getCompleteItemList API call has GetAvailabilityFromCache set to Y. So there have to be entries in inventory_alerts table to return availability picture.
Resolving The Problem
Solution 1:
Configure a custom agent to create entries in the alerts table by calling monitorItemAvailability for the item with infinite inventory.
Solution 2:
Flip the GetAvailabilityFromCache flag to N and ensure that CurrentAvailableQty attribute is present in the output template of above mashup.
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Document Information
Modified date:
16 June 2018
UID
swg21980395