IBM Support

Items with infinite inventory show up as Out of stock

Troubleshooting


Problem

Attempts to create an item with infinite inventory shows item as out of stock in IBM Call Center for Commerce.

Cause

Since there is no explicit inventory adjustment, no entries are made in the yfs_inventory_item table as a result of which no alerts are published by RTAM.

Diagnosing The Problem

The out of the box mashup for getCompleteItemList API call has GetAvailabilityFromCache set to Y. So there have to be entries in inventory_alerts table to return availability picture.

Resolving The Problem

Solution 1:
Configure a custom agent to create entries in the alerts table by calling monitorItemAvailability for the item with infinite inventory.

Solution 2:
Flip the GetAvailabilityFromCache flag to N and ensure that CurrentAvailableQty attribute is present in the output template of above mashup.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.3;9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21980395