IBM Support

Emails from a Guardium Appliance are not being sent by alerter or guard_sender process / Email Testing

Troubleshooting


Problem

Guardium can't send email alerts via the guard_sender process Problem : When alerts or other email are not being sent by the guard_sender process it can often be due to lack of permissions or rights on the email server that the Guardium Appliance is sending to, so it's worth checking this out before assuming Guardium is at fault. NOTE : This may not be a Guardium issue, but Guardium can be seen as the victim !!

Symptom

No email arrives and errors in messages file showing EMAIL FAILED

repeated messages may be seen in the syslog (messages) file as follows

 


<date time> <hostname> guard_sender[nnnn]: Failed to send message.
<date time> <hostname> guard_sender[nnnn]: Error while executing command 'MAIL'.


(The messages file can be seen via fileserver)

 

Cause

Email server not accepting sendmail requests

Resolving The Problem

A common resolution to this problem is for you to request the system ADMIN for the Email server to ADD the Guardium appliance to the trusted list of clients and the email send to the trusted list of users for external email sending.

You may need to contact IBM Technical Support and have them make some specific checks as user root by opening a case with IBM Technical Support.  Reference this article number with the case description.

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Document Information

Modified date:
26 June 2018

UID

swg21980058