IBM Support

Unable to connect Cognos reporting from Control Center

Troubleshooting


Problem

Unable to connect Cognos reporting from Control Center

Symptom

Unable to connect Cognos reporting from Control Center

Cause

Control Center was attempting to connect using the short DNS name

Environment

Control Center 5.4.x.x or later running on UNIX/Linux

Resolving The Problem

Rerun configCC.sh and modify the :
Web Server (WebSphere Liberty) section:

Do you want to reconfigure Web Server(WebSphere Liberty)(Y/N)?y


Are you sure(Y/N)?y

Web Server(WebSphere Liberty) configuration ...
Please provide numeric port value. (Enter 0 to disable) [0] :
Please provide numeric 'Secure' port value. (Enter 0 to disable) [58083] :
Please provide engine host name. [scarecrow] : scarecrow <===make this the fully qualified long DNS name, for example scarecrow.city.state.domain.com.
Please provide listening address for port. [0.0.0.0](0.0.0.0- to listen on all addresses):

You will also need to reenter the COGNOS information so the Cognos startup is redone with the new Liberty host name.

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"5.4;5.4.0.1;5.4.0.2;5.4.1;5.4.2;5.4.2.1;6.0;6.0.0.1;6.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21979915