IBM Support

cdtshell fails with error Incorrect Passphrase

Troubleshooting


Problem

Attempts to run cdtshell command fails with error Incorrect Passphrase in IBM Sterling Order Management

Symptom

The complete error is as follows:
[exec] Starting Configuration Deployment Tool....
     [exec] Starting Comparison....
     [exec] 09:34:29->Estimating Tasks
     [exec] Exception in thread "main" java.lang.Exception: java.lang.
reflect.InvocationTargetException
     [exec]     at com.sterlingcommerce.woodstock.noapp.NoAppLoader.main
(NoAppLoader.java:93)
     [exec] Caused by: java.lang.reflect.InvocationTargetException
     [exec]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
     [exec]     at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java:57)
     [exec]     at sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAccessorImpl.java:43)
     [exec]     at java.lang.reflect.Method.invoke(Method.java:606)
     [exec]     at com.sterlingcommerce.woodstock.noapp.NoAppLoader.main
(NoAppLoader.java:90)
     [exec] Caused by: <?xml version="1.0" encoding="UTF-8"?>
     [exec] <Errors>
     [exec]     <Error ErrorCode="Incorrect Passphrase"
     [exec]         ErrorDescription="Error description not available"
ErrorRelatedMoreInfo="">
     [exec]         <Attribute Name="ErrorCode" Value="Incorrect
Passphrase"/>
     [exec]         <Attribute Name="ErrorDescription" Value="Error
description not available"/>
     [exec]         <Attribute Name="Directory" Value="
/opt/IBM/Sterling/BE-MC-XMLArchive"/>
     [exec]         <Stack>com.yantra.yfc.util.YFCException

Cause


  • Bad or corrupt key in the previous cdt export.


  • The passphrase is not getting passed in the input to the cdt import script.

Diagnosing The Problem

The source is a XML and the target is Oracle database.
Deleting the metadata file cdt_metadata.xml folder and retrying import works fine.
The cdt_metadata.xml file gets generated when you use ExportPassphrase parameter in your export command. This file comprises of password that is used to decrpyt data from the import file. For this to happen, the password should match the password given during export.

Resolving The Problem

As a workaround, you could try the following:

  • Perform a cdt export again and then perform a import.

  • If the ExportPassphrase parameter is being used, ensure that the correct passphrase is being entered during CDT.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg21978774