IBM Support

Calling recordExternalCharges results in over refunds to the customer

Troubleshooting


Problem

Attempts to call recordExternalCharges results in over refunds to the customer in IBM Sterling Order Management.

Symptom

Steps to reproduce:

  1. Created an invoiced order for 49.99

  2. Called requestCollection, a charge for 49.99 was opened. Let this remain in OPEN status

  3. Call recordExternalCharges to record a CHARGE record for 49.99 with request and processed amount as 49.99.

  4. Run requestCollection again. It is seen that a new charge for 49.99 is again opened

This results in two charges of 49.99 each being processed for refunds

Cause

recordExternalCharges was called to record a charge even before the CHARGE record that was created by requestCollection was processed by executeCollection and closed as async.

Resolving The Problem

recordExternalCharges must be called only for CHARGE records that are processed by executeCollection.
Refer the java docs for executeCollection under the section- Additional Information for more information

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2;9.2.1;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21977504