Troubleshooting
Problem
Attempts to run RTAM does not process records when run with AssumeInfiniteInventory set to Y in IBM Sterling Selling and Fulfillment.
Symptom
YFS_INVENTORY_ACTIVITY record is not created when AssumeInfiniteInventory="Y" initially. When AssumeInfiniteInventory is flipped to N , RTAM does not process such record
Cause
There is pre-existing record with '2500-01-01' as next_alert_ts.
Diagnosing The Problem
When AssumeInfiniteInventory="Y", system is designed to create activity record with '2500-01-01' as next_alert_ts. As the system is aware that this is an infinite inventory, it stops RTAM from processing this record. The decision to not process this record increases RTAM throughput and leads to better overall performance. However when AssumeInfiniteInventory is flipped to N, RTAM does not create an activity due to pre-existing record with '2500-01-01'.
Resolving The Problem
This behavior is due to the assumption that a core item attribute flags like AssumeInfiniteInventory will not be flipped during an item life cycle. But, in case of the occasional issue where this flag is set by mistake and requiring a flip, the following are the ways to resolve:
- You can set RaiseEventsOnAllAvailabilityChanges=Y , but this will cause some performance overhead.
OR
- Manually deleting the existing Inventory Activity and creating new activity whenever there are changes in AssumeInfiniteInventory item attribute
OR
- Creating a new activity by calling createInventoryActivityList with Purpose=05 (or ProcessedFlag=F). This would enable RTAM to pick up this record and run RTAM for this item.
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Document Information
Modified date:
16 June 2018
UID
swg21977383