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Sandboxes/Personal Workspace not deleted although they don't appear to be in use

Troubleshooting


Problem

This technote describes when sandboxes/personal workspaces are deleted using one of 3 methods: TI ServerSandboxDelete, using the Reset icon from the application portal or using }tp_delete_sandboxes in Performance Modeler.

Symptom

Sandboxes are not deleted as they are in use but no users are using TM1 Application Web.
Message in TM1 Server.log:
INFO TM1.Sandbox SandboxGlobalAdmin::RunOperation: 'Delete'
Sandbox '[Default]_[}tp_tasks}{guid}].[Europe]_{guid}' matches criteria, but is currently in-use. It will be skipped.
No sandboxes were affected.

Cause

The TI ServerSandboxDelete will not delete a sandbox if it is still in memory.
If you log out of the portal, it unloads the sandbox and will let it be deleted but if you just kill the browser session without logging out, it waits until the session times out before it is released based on the IdleConnectionTimeOutSeconds as set in tm1s.cfg.

Diagnosing The Problem

The TI ServerSandboxDelete will not delete a sandbox if it is still in memory, we see this in the tm1server.log
INFO TM1.Sandbox SandboxGlobalAdmin::RunOperation: 'Delete'
Sandbox '[Default]_[}tp_tasks}{guid}].[Europe]_{guid}' matches criteria, but is currently in-use. It will be skipped.
No sandboxes were affected.

Resolving The Problem

Users should log out of the portal rather than just closing the browser session. However, to ensure no clients are holding onto sandboxes, run sandbox delete after the TM1 server is started.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21977315