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SDK - Model and Report Specification Schema's used in Different Versions of IBM Cognos

Question & Answer


Question

What are the different schema versions used for Model and Report in IBM Cognos ?

Cause

Potential errors are failure to run a Report from an older version in a newer Server version, they will appear in the logs when version incompatibility exists.
Highly likely RSV-SRV (Report Server ) and QE-DEF ( Query Engine Definition ) type of Errors will result.

Answer

There is a Model Schema that is by default used in IBM Cognos, and its version can change with each new Major or Minor version installation of the Cognos Product.

Because a higher model schema will not be backwards compatible with any Cognos software, it is important to recognise that a Fix Pack may need to be installed on the Server , or any of the used Client Software to avoid errors or problems to occur.

Modelling and Specification capable components are part of the Client tools , such as Framework Manager , BmtScriptPlayer executable , the SDK API's , inclusive Diagnostic Tools designed for that purpose.

This difference in version causes issues , applies to Framework Manager , the SDK API's for FM and Models , and any other tools that create Report , Query or Analytic specifications , including Custom API code that manages these.

It is therefore very important to have , and work with the same version of any Client Tool or Software API , as that is used for the IBM Cognos Server you have intended and deployed your Custom Applications for.
A differences in version between software and Tooling for the IBM Cognos Server is not supported, and most certainly will cause errors to appear.

IBM Cognos Framework Manager - Model Schema Specifications used in Versions

CRN 1.0 = Model Schema /30/3
CRN 1.1 = Model Schema /30/3
CRN 1.1.4 = Model Schema /32/3
C8.1.0 = Model Schema /60/0
C8.2.0 = Model Schema /60/0
C8.3.0 = Model Schema /60/0
C8.4.0 = Model Schema /60/1
C8.4.1 = Model Schema /60/1
C10.1.0 = Model Schema /60/2
C10.1.1 = Model Schema /60/3
C10.2.0.0 = Model Schema /60/3 Initial GA to FixPack 5 releases
C10.2.1.0 = Model Schema /60/5 Initial GA release
C10.2.1.x = Model Schema /60/7 FixPack 1 through FixPack 12 releases
C10.2.2.0 = Model Schema /60/10
C10.2.2.x = Model Schema /60/11 FixPack 1 through FixPack 7 releases
C11.0.0.0 = Model Schema /60/11
C11.0.1.0 = Model Schema /60/11
C11.0.2.0 = Model Schema /60/11
C11.0.3.0 = Model Schema /60/11
C11.0.4.0 = Model Schema /60/11
C11.0.5.0 = Model Schema /60/12
C11.0.6.0 = Model Schema /60/12
C11.0.7.0 = Model Schema /60/12
C11.0.8.0 = Model Schema /60/12
C11.0.9.0 = Model Schema /60/12

Upgrade Information :
Opening the Model in an updated Framework Manager version, and saving the Model to the file system, will upgrade the model to the new version.
Such updated models can no longer be opened in a previous version, and any "cracks" or "hacks" are not supported by IBM Cognos Software development.
Recommend since there is no going back from this upgrade , is to keep Model backups of what was designed earlier.

IBM Cognos - Report Schema Specifications used in Versions

CRN = Report Schema 1
C8.1.0 = Report Schema 2
C8.2.0 = Report Schema 3
C8.3.0 = Report Schema 4
C8.4.0 = Report Schema 5
C8.4.1 = Report Schema 6
C10.1.0 = Report Schema 7
C10.1.1 = Report Schema 8
C10.2.0 = Report Schema 9
C10.2.1 = Report Schema 10
C10.2.1.1 = Report Schema 11
C10.2.2 = Report Schema 12
C11.0.0.0 = Report Schema 13
C11.0.1.0 = Report Schema 13
C11.0.2.0 = Report Schema 13
C11.0.3.0 = Report Schema 13.1
C11.0.4.0 = Report Schema 13.2
C11.0.5.0 = Report Schema 13.3
C11.0.6.0 = Report Schema 14
C11.0.7.0 = Report Schema 14.1
C11.0.8.0 = Report Schema 14.2
C11.0.9.0 = Report Schema 14.2

Upgrade Information :
Reports can be upgraded to the later Schema Version by :
- Import Deployment , with the option "Upgrade all Reports" specified in the Import for CM in Administration.
- Import Deployment , followed by Open the Report is Report Studio, validate - address Errors / Warnings , Save the Report again in Report Studio back to CM.
- Import Report Specification in Report Studio, validate - address Errors / Warnings and Save the Report as a new Report in Content Manager / Content Store.
- Using the SDK API in an Application for this purpose.

Schema backups also need to be implemented to ensure reports can be reverted back to earlier version execution if so needed.

For further details see the online documentation for the IBM Cognos Products.

Related Information

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Software Development Kit","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Software Development Kit (SDK) v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
24 February 2020

UID

swg21975170