IBM Support

Support for RCP PCA clients across versions in Sterling Selling and Fulfillment Suite

Question & Answer


Question

Can client from a lower version(say 9.2 or 9.2.1) be used to connect with the latest foundation(9.4 or 9.5)?

Cause

In an typical implementation. the RCP(Rich Client Platform) clients are customized to suit each customer's requirements. When upgrading to a recent version of the product, customers might need to continue using the earlier clients until the customization can be deployed and tested with the latest clients.

Answer

RCP clients version 9.3 is certified to work with Foundation 9.4 and 9.5. No other clients are certified except version 9.3.

The support for old PCA(Packaged Composite Applications) clients with new runtimes is provided via a "Phased deployment solution", where in customer would maintain two runtimes - the old inactive one to build and install the clients, and the new active/upgraded runtime from which the SSFS deployment is generated. Refer detailed documentation here.

Considering an example of upgrading from 9.2 to 9.4, the flow here should be:
- as database(DB) is migrated from 9.2, the 9.4 migrated DB should have all the COM(Call Center Order Management) PCA factory set up
- no need to install PCA on 9.4 runtime
- maintain 9.2 runtime to build the client
- follow the steps provided in doc link above to copy the ycml, re-generate resources.jar and rebuild the EAR

Note: Details on 9.3 client certified to work with Foundation 9.4 : here.

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Document Information

Modified date:
16 June 2018

UID

swg21975136