IBM Support

Agents/Integration servers throw java.lang.reflect.InvocationTargetException

Troubleshooting


Problem

Attempts to run agents/integration servers leads to the Error ErrorCode="java.lang.reflect.InvocationTargetException" in IBM Sterling Order Management.

Symptom

The complete error is:

<Error ErrorCode="java.lang.reflect.InvocationTargetException"
       ErrorDescription="Error_description_not_available"
       ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="172.16.232.5514499400272980000000004827">
       <Attribute Name="ErrorCode" Value="java.lang.reflect.InvocationTargetException"/>
       <Attribute Name="ErrorDescription" Value="Error_description_not_available"/>
       <Error ErrorCode="java.lang.reflect.InvocationTargetException" ErrorDescription="" ErrorRelatedMoreInfo="">

Cause

This error is a symptom of jar mismatch or a potential deployment issue.

Resolving The Problem

Ensure that the Agent configuration file (AgentDynamicClassPath.cfg) does not have duplicate entries for jars containing the same class.

For example:
The duplicate entry in this case was:VENDOR_JAR=/opt/IBM/Sterling93/jar/websphere/85/com.ibm.jaxrs.thinclient_8.5.0.jar

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Maintenance","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF034","label":"Windows Mobile"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2;9.2.1;9.3;9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21973927