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Problems with P8 CE Health page

Troubleshooting


Problem

P8 Content Engine Health page does not display green icons for valid configurations.

Symptom

Logs contain:

FNRCA0031E: API_UNABLE_TO_USE_CONNECTION: The URI for server communication cannot be determined from the connection object
Error: A communication failure occurred while attempting to obtain an initial context with the provider URL

Cause

WebSphere host cannot resolve the host name in the originating URL to the correct IP address for the destination port in WebSphere.

Environment

FileNet P8 Content Engine deployed on WebSphere Application Server

Diagnosing The Problem

  • Access the P8 CE Health page. Currently configured properties are shown with a red icon instead of a green icon for valid existing configuration objects. Server logs contain the messages shown above.
  • Access the WebSphere Admin console and navigate to the 'Ports' configuration for the Application server. Note down the host name or IP address associated with the EJB/ORB - bootstrap port (default 2809) and the WC_defaulthost (default 9080) and the WC_defaulthost_secure ports.
  • Use local server tools such as nslookup and ping to check name and IP address resolution. Other additional tools are available on particular UNIX and Linux platforms.
  • Check DNS name resolution for both the short host name and the fully qualified DNS host name. Make sure they resolve to the same IP address.
  • Check the local etc/HOSTS file. If the local HOSTS file contains entries for this host, ensure that both the short and fully qualified name are associated with the correct local IP address, and match the name or address used in the WebSphere Port configuration.
  • This issue is very common on dual homed systems, where there is more than one network interface, and one interface is for client/public traffic and the other is an internal management interface.
  • For example: A server named filenetDEV has two NIC cards with IP addresses 10.1.1.75 and 137.99.99.75 respectively. If the WC_defaulthost port is configured in WebSphere against the host name filenetDEV, and the local HOSTS file contains an entry for filenetDEV against local IP address 10.1.1.75, then the port will be listening for requests received against IP address 10.1.1.75 only.

    If the source URL to access the CE Health page contains the fully qualified host name filenetDEV.filenet.com, and in DNS this resolves to 137.99.99.75, calls will fail, because the WebSphere Application server port is not listening on this IP address.

Resolving The Problem

Ensure that the WebSphere port is listening on the required IP address (based on host name address resolution) and that the host name used in the originating URL resolves to the listening IP address on the local server. NOTE: In some WebSphere configuration fields a wild card * can be used to mean ALL local IP addresses. There is additional information in this related technote.

Often the simplest solution is to edit the local HOSTS file and add both the short name and fully qualified name to the required local IP address.

For example:

137.99.99.75 filenetDEV filenetDEV.filenet.com #WAS CE Listening address

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.2.1;5.2.0;5.1.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21965902