Question & Answer
Question
How do you reship orderlines in a drop ship scenario in IBM Sterling Selling and Fulfillment?
Cause
In a drop ship scenario, orderline on the sales order will not have a reship since the sales order doesn't have any shipments.
Answer
The getReshippableOrderLines API returns a list of order lines which are in a state that can be reshipped. Even though the reship window and reship reasons are appropriately configured, the getOrderDetails API and the getReshippableOrderLines API might not return the same set of orderlines. This is because reshipping is only supported for lines that go through the shipment process. In the drop ship case, the chained order (drop ship) is the one with a shipment. So, you have to reship that line on the chained order.
Hence, the corresponding orderline on the sales order will not have a reship since the sales order doesn't have any shipments. Product doesn't support reshipping lines that don't have shipments. This is why yo must do reship on the drop ship (PO) instead of the sales order. So, only the PO will have a new line.
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Document Information
Modified date:
16 June 2018
UID
swg21964570