IBM Support

Connecting to Citrus Payment Gateway from Agent leads to java.net.SocketException: java.lang.ClassNotFoundException

Troubleshooting


Problem

Attempts to connect to Citrus Payment Gateway from Agent server throws the error java.net.SocketException: java.lang.ClassNotFoundException: Cannot find the specified class com.ibm.websphere.ssl.protocol.SSLSocketFactory in IBM Sterling Selling and Fulfillment.

Symptom

Below exception seen while connecting to Citrus Payment Gateway from collection credit card User exit implemented.
com.yantra.omp.api.OMPUserExitProxy.collectionDebitCard(OMPUserExitProxy.java:1583)   at
com.yantra.omp.business.payment.YFSExecuteCollection.callUserExits(YFSExecuteCollection.java:832) at com.yantra.omp.business.payment.YFSExecuteCollection.invokeCollectionUserExit(YFSExecuteCollection.java:503)  at com.yantra.omp.business.payment.YFSExecuteCollection.
executeCollection(YFSExecuteCollection.java:474)  at com.yantra.omp.business.payment.YFSExecuteCollection.executeCollection(YFSExecuteCollection.java:282) at com.yantra.omp.business.payment.YFSExecuteCollection.executeCollection(YFSExecuteCollection.java:169) at com.yantra.omp.business.payment.YFSExecuteCollection.executeCollection(YFSExecuteCollection.java:139) at com.yantra.omp.agent.YFSExecuteCollectionAgent.executeJob(YFSExecuteCollectionAgent.java:98)at com.yantra.ycp.agent.server.YCPAbstractAgent.executeOneJob(YCPAbstractAgent.java:412)at com.yantra.ycp.agent.server.YCPAbstractAgent.processMessage(YCPAbstractAgent.java:314)at com.yantra.ycp.agent.server.YCPAbstractAgent.run(YCPAbstractAgent.java:175)at sun.reflect.GeneratedMethodAccessor59.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)at java.lang.reflect.Method.invoke(Method.java:613) at com.yantra.interop.services.api.ApiHelper.invoke(ApiHelper.java:456)

Cause

The Agent server is pointing to JDK location of WebSphere Application Server or JDK copied from WebSphere Application Server location which has security.provider and ssl.SocketFactory.provider specific for WebSphere Application Server

Resolving The Problem

Steps to resolve:

Point to the proper IBM JDK installation in agent server configuration

OR

Copy and replace java.security file from proper IBM JDK installation to <JDK_INSTALL_DIR>/jre/lib/security and restart agent server

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21963844